LEGO® Batman 'The Batmersive Experience' System Requirements

Last updated: 21 October 2021

Curious if your PC can run LEGO® Batman 'The Batmersive Experience'? On this page you will find LEGO® Batman 'The Batmersive Experience' system requirements for PC (Windows). We constantly update our data to provide you with latest and most accurate requirements.

Test your PC to see if it will run LEGO® Batman 'The Batmersive Experience' or check system requirement details for CPU, operating system, graphics and sound cards, required disk space and more for each of the supported platforms.

Table of Contents

Can I run it: LEGO® Batman 'The Batmersive Experience'

Will it run? According to our tests, 0% of people can run it on their PC. Test your PC now!
View most recent tests.

Can my PC run LEGO® Batman 'The Batmersive Experience'?

Sysrqmts browser extension icon
Not sure what hardware you have?
Install our Chrome extension to autofill this information.

  1. Right-click the Windows icon in the bottom left-hand corner of your screen
  2. Click on the ‘System’ Tab in the pop-up menu
  3. Your computer’s CPU name will be displayed under ‘Device Specifications > Processor’

  1. Right-click the Windows icon in the bottom left-hand corner of your screen
  2. In the opened menu click on ‘Device Manager’
  3. In ‘Device Manager’ click on the arrow next to ‘Display adapters’
  4. Under the drop-down, you will see the GPU that your computer is using

  1. Right-click the Windows icon in the bottom left-hand corner of your screen
  2. Click on the ‘System’ Tab in the pop-up menu
  3. Your computer’s RAM will be displayed under ‘Device Specifications > Installed RAM’

  1. Right-click the Windows icon in the bottom left-hand corner of your screen
  2. Click on the ‘System’ Tab in the pop-up menu
  3. You can see if Windows is 64 or 32 bit under ‘System type’
  4. You can see Windows version under ‘Windows edition’

Check if you can run these popular games too!

LEGO® Batman 'The Batmersive Experience' Windows Requirements

LEGO® Batman 'The Batmersive Experience' system requirements for Windows
Minimum Requirements
OS
OS
Windows 10 Only
Processor
Processor
Memory
Memory
4 GB
Graphics
Graphics
Network
Network
Broadband Internet connection
Storage
Storage
50 MB
Additional Notes
Additional Notes
Bandwidth requirements depend on the resolution and quality of the video being played. Please see the Steam 360 Video FAQ for more information.

LEGO® Batman 'The Batmersive Experience' minimum requirements for Windows assume having at least Windows 10 Only operating system. Your processor should be Intel i5-4590, AMD FX 8350 equivalent or a more powerful one. The minimum RAM requirement is 4 GB. As for a graphics card, it should be NVIDIA GeForce GTX 970, AMD Radeon™ R9 290 equivalent. You also have to have 50 MB free disk space to install the game.

LEGO® Batman 'The Batmersive Experience' Mac Requirements

LEGO® Batman 'The Batmersive Experience' system requirements for Mac
Minimum Requirements
OS
OS
Windows 10 Only
Processor
Processor
Memory
Memory
4 GB
Graphics
Graphics
Network
Network
Broadband Internet connection
Storage
Storage
50 MB
Additional Notes
Additional Notes
Bandwidth requirements depend on the resolution and quality of the video being played. Please see the Steam 360 Video FAQ for more information.

As for Mac OS, LEGO® Batman 'The Batmersive Experience' requirements here start with Windows 10 Only operating system. Processor needs to be at least Intel i5-4590, AMD FX 8350 equivalent. 4 GB of RAM is required. Your graphics card should be NVIDIA GeForce GTX 970, AMD Radeon™ R9 290 equivalent. Finally, the game needs 50 MB of free disk space.

LEGO® Batman 'The Batmersive Experience' Linux Requirements

LEGO® Batman 'The Batmersive Experience' system requirements for Linux
Minimum Requirements
OS
OS
Windows 10 Only
Processor
Processor
Memory
Memory
4 GB
Graphics
Graphics
Network
Network
Broadband Internet connection
Storage
Storage
50 MB
Additional Notes
Additional Notes
Bandwidth requirements depend on the resolution and quality of the video being played. Please see the Steam 360 Video FAQ for more information.

If you’re on Linux, minimum requirements include Windows 10 Only. Processor should be Intel i5-4590, AMD FX 8350 equivalent or higher. For RAM you need 4 GB or more. Graphics card should be NVIDIA GeForce GTX 970, AMD Radeon™ R9 290 equivalent or better. 15GB of free disk space is a must.

Game Details

Release date
10 May, 2017
Category
Native Steam Controller Support
Genres
Movie, 360 Video
Supported languages
English*
* languages with full audio support
Developer
Warner Bros.
Publisher
Warner Bros.
Support website
store.steampowered.com

FAQs

Can I run LEGO® Batman 'The Batmersive Experience'?

You would be able to run LEGO® Batman 'The Batmersive Experience' on your PC if it meets minimum requirements below. You can also use our free test tool to check it!

Minimum requirements for Windows are:

Minimum requirements for Mac are:

Minimum requirements for Linux are:

Can I play LEGO® Batman 'The Batmersive Experience' with 3 GB of RAM?

No, this is not enough to play LEGO® Batman 'The Batmersive Experience'. The minimum RAM is 4 GB.

Can I play LEGO® Batman 'The Batmersive Experience' with 4 GB of RAM?

Yes, LEGO® Batman 'The Batmersive Experience' can run with 4 GB of RAM. It's a minimum requirement.

How much RAM does LEGO® Batman 'The Batmersive Experience' need?

You need at least 4 GB of RAM to run LEGO® Batman 'The Batmersive Experience' on PC.

On Mac it requires minimum 4 GB.

And on Linux/SteamOS: 4 GB minimum.

What processor do I need for LEGO® Batman 'The Batmersive Experience'?

Intel i5-4590, AMD FX 8350 equivalent is a minimum requirement for PC to be able to run LEGO® Batman 'The Batmersive Experience'.

How many GB is LEGO® Batman 'The Batmersive Experience'?

At least 50 MB of disk space is required to install LEGO® Batman 'The Batmersive Experience' on your PC.

What graphics card do I need for LEGO® Batman 'The Batmersive Experience'?

You need NVIDIA GeForce GTX 970, AMD Radeon™ R9 290 equivalent or more powerful video card.

What version of Windows can I use to play LEGO® Batman 'The Batmersive Experience'?

Windows 10 Only or newer.

Can I run LEGO® Batman 'The Batmersive Experience' on my laptop?

Yes, as long as it meets minimum requirements above.

Can I play LEGO® Batman 'The Batmersive Experience' on my Mac?

Yes, LEGO® Batman 'The Batmersive Experience' supports Mac if it meets the following minimum requirements:

Can I run LEGO® Batman 'The Batmersive Experience' on Linux/SteamOS?

Yes, you can play LEGO® Batman 'The Batmersive Experience' on Steam OS/Linux. Please see requirements above.

When is LEGO® Batman 'The Batmersive Experience' release date?

LEGO® Batman 'The Batmersive Experience' release date is 10 May, 2017.

Recent Tests

Sysrqmts browser extension icon
Stop overpaying for PC games!
See cheapest prices in Steam store with our browser extension.