They Bleed Pixels System Requirements

Last updated: 23 May 2022

Curious if your PC can run They Bleed Pixels? On this page you will find They Bleed Pixels system requirements for PC (Windows, Mac and Linux). We constantly update our data to provide you with latest and most accurate requirements.

Test your PC to see if it will run They Bleed Pixels or check system requirement details for CPU, operating system, graphics and sound cards, required disk space and more for each of the supported platforms.

Table of Contents

Can I run it: They Bleed Pixels

Will it run? According to our tests, 33% of people can run it on their PC. Test your PC now!
View most recent tests.

Can my PC run They Bleed Pixels?

Sysrqmts browser extension icon
Not sure what hardware you have?
Install our Chrome extension to autofill this information.

  1. Right-click the Windows icon in the bottom left-hand corner of your screen
  2. Click on the ‘System’ Tab in the pop-up menu
  3. Your computer’s CPU name will be displayed under ‘Device Specifications > Processor’

  1. Right-click the Windows icon in the bottom left-hand corner of your screen
  2. In the opened menu click on ‘Device Manager’
  3. In ‘Device Manager’ click on the arrow next to ‘Display adapters’
  4. Under the drop-down, you will see the GPU that your computer is using

  1. Right-click the Windows icon in the bottom left-hand corner of your screen
  2. Click on the ‘System’ Tab in the pop-up menu
  3. Your computer’s RAM will be displayed under ‘Device Specifications > Installed RAM’

  1. Right-click the Windows icon in the bottom left-hand corner of your screen
  2. Click on the ‘System’ Tab in the pop-up menu
  3. You can see if Windows is 64 or 32 bit under ‘System type’
  4. You can see Windows version under ‘Windows edition’

Check if you can run these popular games too!

Buy They Bleed Pixels

You can buy They Bleed Pixels directly on Steam, or on one of the marketplaces below. Usually, games on marketplaces are much cheaper, and you can save up to 80%! Check prices below:

Shop Product Price

They Bleed Pixels Windows Requirements

They Bleed Pixels system requirements for Windows
Minimum Requirements Recommended Requirements
OS
OS
Windows XP sp 3 .
OS
Processor
Processor
CPU 1.2GHz or Faster
Processor
CPU 1.73Gz or Faster
Memory
Memory
512 MB
Memory
Graphics
Graphics
OpenGL 3.0+, 2.1 with ARB extensions acceptable
Graphics
Recent Intel HD Graphics .
Storage
Storage
250 MB
Storage
Controller support
Controller support
Any SDL 2.0 compatible controller (DirectInput/Xinput) including the Xbox 360 Controller.
Controller support

They Bleed Pixels minimum requirements for Windows assume having at least Windows XP sp 3 . operating system. Your processor should be CPU 1.2GHz or Faster or a more powerful one. The minimum RAM requirement is 512 MB. As for a graphics card, it should be OpenGL 3.0+, 2.1 with ARB extensions acceptable. You also have to have 250 MB free disk space to install the game.

Recommended CPU would be CPU 1.73Gz or Faster CPU or equivalent. And video card — Recent Intel HD Graphics ..

They Bleed Pixels Mac Requirements

They Bleed Pixels system requirements for Mac
Minimum Requirements Recommended Requirements
OS
OS
10.9 Mavericks
OS
Processor
Processor
CPU 1.2GHz or Faster
Processor
CPU 1.73Gz or Faster
Memory
Memory
512 MB
Memory
Graphics
Graphics
OpenGL 3.0+, 2.1 with ARB extensions acceptable
Graphics
Recent Intel HD Graphics .
Storage
Storage
250 MB
Storage
Controller support
Controller support
Any SDL 2.0 compatible controller (DirectInput/Xinput) including the Xbox 360 Controller.
Controller support

As for Mac OS, They Bleed Pixels requirements here start with 10.9 Mavericks operating system. Processor needs to be at least CPU 1.2GHz or Faster. 512 MB of RAM is required. Your graphics card should be OpenGL 3.0+, 2.1 with ARB extensions acceptable. Finally, the game needs 250 MB of free disk space.

CPU 1.73Gz or Faster processor is recommended. Your video card should be Recent Intel HD Graphics ..

They Bleed Pixels Linux Requirements

Requires 64 bit processor and operating system.

They Bleed Pixels system requirements for Linux
Minimum Requirements Recommended Requirements
OS
OS
glibc 2.17+ only
OS
Processor
Processor
CPU 1.2GHz or Faster
Processor
CPU 1.73Gz or Faster
Memory
Memory
512 MB
Memory
Graphics
Graphics
OpenGL 3.0+, 2.1 with ARB extensions acceptable
Graphics
Recent Intel HD Graphics .
Storage
Storage
250 MB
Storage
Controller support
Controller support
Any SDL 2.0 compatible controller (DirectInput/Xinput) including the Xbox 360 Controller.
Controller support

If you’re on Linux, minimum requirements include glibc 2.17+ only. Processor should be CPU 1.2GHz or Faster or higher. For RAM you need 512 MB or more. Graphics card should be OpenGL 3.0+, 2.1 with ARB extensions acceptable or better. 15GB of free disk space is a must.

As for the processor/CPU, use CPU 1.73Gz or Faster or equivalent. And make sure you have Recent Intel HD Graphics . graphics card.

Game Details

They Bleed Pixels is a fiendishly difficult action platformer inspired by H.P. Lovecraft and classic horror.

Release date
29 August, 2021
Metacritic score
74/100
OpenCritic Score
0.00/100
Category
Single-player
Genres
Action, Indie
Supported languages
English, Japanese
* languages with full audio support
Developer
Spooky Squid Games Inc.
Publisher
Spooky Squid Games Inc.
Official website
theybleedpixels.com
Support website
[email protected]
Support website
store.steampowered.com

FAQs

Can I run They Bleed Pixels?

You would be able to run They Bleed Pixels on your PC if it meets minimum requirements below. You can also use our free test tool to check it!

Minimum requirements for Windows are:

  • OS: Windows XP sp 3 .
  • Processor: CPU 1.2GHz or Faster
  • Memory: 512 MB
  • Graphics: OpenGL 3.0+, 2.1 with ARB extensions acceptable
  • Storage: 250 MB
  • Controller support: Any SDL 2.0 compatible controller (DirectInput/Xinput) including the Xbox 360 Controller.

Minimum requirements for Mac are:

  • OS: 10.9 Mavericks
  • Processor: CPU 1.2GHz or Faster
  • Memory: 512 MB
  • Graphics: OpenGL 3.0+, 2.1 with ARB extensions acceptable
  • Storage: 250 MB
  • Controller support: Any SDL 2.0 compatible controller (DirectInput/Xinput) including the Xbox 360 Controller.

Minimum requirements for Linux are:

  • OS: glibc 2.17+ only
  • Processor: CPU 1.2GHz or Faster
  • Memory: 512 MB
  • Graphics: OpenGL 3.0+, 2.1 with ARB extensions acceptable
  • Storage: 250 MB
  • Controller support: Any SDL 2.0 compatible controller (DirectInput/Xinput) including the Xbox 360 Controller.

How much RAM does They Bleed Pixels need?

You need at least 512 MB of RAM to run They Bleed Pixels on PC.

On Mac it requires minimum 512 MB.

And on Linux/SteamOS: 512 MB minimum.

What processor do I need for They Bleed Pixels?

CPU 1.2GHz or Faster is a minimum requirement for PC to be able to run They Bleed Pixels.

How many GB is They Bleed Pixels?

At least 250 MB of disk space is required to install They Bleed Pixels on your PC.

What graphics card do I need for They Bleed Pixels?

You need OpenGL 3.0+, 2.1 with ARB extensions acceptable or more powerful video card.

What version of Windows can I use to play They Bleed Pixels?

Windows XP sp 3 . or newer.

Can I run They Bleed Pixels on my laptop?

Yes, as long as it meets minimum requirements above.

Can I play They Bleed Pixels on my Mac?

Yes, They Bleed Pixels supports Mac if it meets the following minimum requirements:

  • OS: 10.9 Mavericks
  • Processor: CPU 1.2GHz or Faster
  • Memory: 512 MB
  • Graphics: OpenGL 3.0+, 2.1 with ARB extensions acceptable
  • Storage: 250 MB
  • Controller support: Any SDL 2.0 compatible controller (DirectInput/Xinput) including the Xbox 360 Controller.

Can I run They Bleed Pixels on Linux/SteamOS?

Yes, you can play They Bleed Pixels on Steam OS/Linux. Please see requirements above.

When is They Bleed Pixels release date?

They Bleed Pixels release date is 29 August, 2021.

Recent Tests

Sysrqmts browser extension icon
Stop overpaying for PC games!
See cheapest prices in Steam store with our browser extension.